flutter_sensitive_content 0.0.2 copy "flutter_sensitive_content: ^0.0.2" to clipboard
flutter_sensitive_content: ^0.0.2 copied to clipboard

A Flutter package for hiding the sensitive content of your app when you switch from one app to another. This way, no sensitive pieces of information are shown while the app previews.

10
likes
130/ 140
pub points
49%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 19 API elements (36.8 %) have documentation comments.

Some symbols that are missing documentation: flutter_sensitive_content, flutter_sensitive_content.SensitiveContent, flutter_sensitive_content.SensitiveContent.child, flutter_sensitive_content.SensitiveContent.publicContent, lazy_indexed_stack.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_sensitive_content/flutter_sensitive_content.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_sensitive_content/flutter_sensitive_content.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_sensitive_content/flutter_sensitive_content.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_sensitive_content/flutter_sensitive_content.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

10
likes
130
pub points
49%
popularity

Publisher

unverified uploader

A Flutter package for hiding the sensitive content of your app when you switch from one app to another. This way, no sensitive pieces of information are shown while the app previews.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_sensitive_content