flutter_segment 3.0.0
flutter_segment: ^3.0.0 copied to clipboard

Flutter Android iOS web

Flutter implementation of Segment Analytics for iOS, Android and Web

22
likes
90 / 110
pub points
89 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 26 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_segment/flutter_segment.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'messenger' is deprecated and shouldn't be used. This property is redundant. It returns the object on which it is called. This feature was deprecated after v1.24.0-7.0.pre..

lib/src/segment_web.dart:11:17

   ╷
11 │       registrar.messenger,
   │                 ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/segment_web.dart

lib/src/segment.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
meta^1.0.01.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
js-0.6.30.6.3
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.