flutter_scaffold 0.0.12+2
flutter_scaffold: ^0.0.12+2

Dart

To be able to generate file structure

0
likes
45 / 110
pub points
22 %
popularity

We analyzed this package on Dec 5, 2020, and awarded it 45 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

CHANGELOG.md is empty.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: `Future` results in `async` function bodies must be `await`ed or marked `unawaited` using `package:pedantic`.

bin/flutter_scaffold.dart:15:5

   ╷
15 │     ..run(arguments);
   │     ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/flutter_scaffold.dart

INFO: 'package:resource/resource.dart' is deprecated and shouldn't be used. This package has been discontinued. See library documentation of README.md for more infomration.

bin/src/component.dart:5:1

  ╷
5 │ import 'package:resource/resource.dart' show Resource;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/src/component.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.01.6.0
meta^1.1.81.2.41.2.4
mustache^1.1.11.1.11.1.1
recase^2.0.12.0.13.0.1
resource^2.1.62.1.72.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.14.131.14.13
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on recase does not support the latest published version `3.0.1`

pubspec.yaml:17:11

   ╷
17 │   recase: ^2.0.1
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs