flutter_rtmp 0.1.4
flutter_rtmp: ^0.1.4 copied to clipboard

Flutter Android iOS

A rtmp plugin.Support both iOS and Android. It has been upload to github.

3
likes
80 / 110
pub points
32 %
popularity

We analyzed this package on Mar 6, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 52 API elements (23.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_rtmp/flutter_rtmp.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Unused import: 'package:flutter_rtmp/src/def.dart'.

lib/src/rtmp_view.dart:12:8

   ╷
12 │ import 'package:flutter_rtmp/src/def.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/rtmp_view.dart

INFO: Unused import: 'package:permission_handler/permission_handler.dart'.

lib/src/rtmp_view.dart:14:8

   ╷
14 │ import 'package:permission_handler/permission_handler.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/rtmp_view.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
permission_handler^3.2.03.3.06.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.2.0` on permission_handler does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

3
likes
80
pub points
32%
popularity

A rtmp plugin.Support both iOS and Android. It has been upload to github.

Homepage

Documentation

API reference

Uploader

makewei2@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, permission_handler

More

Packages that depend on flutter_rtmp