flutter_rich_editor 0.0.1
flutter_rich_editor: ^0.0.1 copied to clipboard

Flutter Android iOS web

Flutter Pell Rich Text Editor.

2
likes
80 / 110
pub points
36 %
popularity

We analyzed this package on Jan 23, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  warning: rich_eidtor has no library level documentation comments, from rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/RichEditor.dart:1:9)
  warning: rich_eidtor has no library level documentation comments, from rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/RichToolbar.dart:1:9)
  error: failed to write file at: rich_eidtor/rich_eidtor-library.html
    for symbol rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/RichToolbar.dart:1:9)
    conflicting with file already generated by rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/RichEditor.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            rich_eidtor conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: rich_eidtor has no library level documentation comments, from rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/const.dart:1:9)
  error: failed to write file at: rich_eidtor/rich_eidtor-library.html
    for symbol rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/const.dart:1:9)
    conflicting with file already generated by rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/RichToolbar.dart:1:9)
  warning: rich_eidtor has no library level documentation comments, from rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/editor.dart:1:9)
  error: failed to write file at: rich_eidtor/rich_eidtor-library.html
    for symbol rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/editor.dart:1:9)
    conflicting with file already generated by rich_eidtor: (file:///tmp/pub-dartlang-dartdocQGYIUI/pkg/lib/const.dart:1:9)
found 4 warnings and 3 errors
Unhandled exception:
dartdoc encountered 3 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:231:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/RichEditor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/RichToolbar.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs