flutter_remote_ui 0.0.4+6 copy "flutter_remote_ui: ^0.0.4+6" to clipboard
flutter_remote_ui: ^0.0.4+6 copied to clipboard

bridged's remote-ui for flutter app. bump your flutter project to enterprise level

5
likes
30/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/softmarshmallow/remote-ui/tree/master/flutter was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_remote_ui,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: flutter_remote_ui.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.1.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.3. Cannot run `flutter pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.3.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.3)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

5
likes
30
pub points
0%
popularity

Publisher

verified publishergrida.co

bridged's remote-ui for flutter app. bump your flutter project to enterprise level

Homepage
Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter, flutter_svg, grpc, json_annotation, x_color, x_icon

More

Packages that depend on flutter_remote_ui