flutter_readmore 0.0.2 copy "flutter_readmore: ^0.0.2" to clipboard
flutter_readmore: ^0.0.2 copied to clipboard

discontinued

A new Flutter project.

4
likes
70/ 160
pub points
66%
popularity

We analyzed this package 4 days ago, and awarded it 70 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/BhaveshSachala/flutter_readmore.git was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_readmore,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 28 API elements (32.1 %) have documentation comments.

Some symbols that are missing documentation: flutter_readmore, flutter_readmore.ReadMore, flutter_readmore.ReadMore.ReadMore, flutter_readmore.ReadMore.colorClickableText, flutter_readmore.ReadMore.data.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

ERROR: The getter 'accentColor' isn't defined for the type 'ThemeData'.

lib/flutter_readmore.dart:102:56

    ╷
102 │         widget.colorClickableText ?? Theme.of(context).accentColor;
    │                                                        ^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_readmore.dart

INFO: 'textScaleFactorOf' is deprecated and shouldn't be used. Use textScalerOf instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/flutter_readmore.dart:97:46

   ╷
97 │         widget.textScaleFactor ?? MediaQuery.textScaleFactorOf(context);
   │                                              ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_readmore.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • UNDEFINED_GETTER - lib/flutter_readmore.dart:102:56 - The getter 'accentColor' isn't defined for the type 'ThemeData'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.