flutter_qr_reader 1.0.5 copy "flutter_qr_reader: ^1.0.5" to clipboard
flutter_qr_reader: ^1.0.5 copied to clipboard

QR code (scan QRCode and picture) recognition (AndroidView/UiKitView)

77
likes
115/ 140
pub points
92%
popularity

We analyzed this package 2 days ago, and awarded it 115 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_qr_reader, flutter_qr_reader.FlutterQrReader, flutter_qr_reader.FlutterQrReader.FlutterQrReader, flutter_qr_reader.FlutterQrReader.imgScan, flutter_qr_reader.QrReaderView.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_qr_reader/flutter_qr_reader.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_qr_reader/flutter_qr_reader.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_qr_reader/flutter_qr_reader.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_qr_reader/flutter_qr_reader.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/flutter_qr_reader.dart:56:36

   ╷
56 │           "width": (widget.width * window.devicePixelRatio).floor(),
   │                                    ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_qr_reader.dart

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/flutter_qr_reader.dart:57:38

   ╷
57 │           "height": (widget.height * window.devicePixelRatio).floor(),
   │                                      ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_qr_reader.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

77
likes
115
pub points
92%
popularity

Publisher

unverified uploader

QR code (scan QRCode and picture) recognition (AndroidView/UiKitView)

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_qr_reader