flutter_qjs 0.3.7 copy "flutter_qjs: ^0.3.7" to clipboard
flutter_qjs: ^0.3.7 copied to clipboard

This plugin is a simple js engine for flutter using the `quickjs` project. Plugin currently supports all the platforms except web!

29
likes
110/ 140
pub points
69%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 41 API elements (51.2 %) have documentation comments.

Some symbols that are missing documentation: flutter_qjs, flutter_qjs.IsolateFunction.destroy, flutter_qjs.IsolateFunction.dup, flutter_qjs.IsolateFunction.free, flutter_qjs.IsolateFunction.invoke.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:flutter_qjs/flutter_qjs.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

WARNING: This API is available since SDK 2.16.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/wrapper.dart:167:26

    ╷
167 │       final size = psize.value;
    │                          ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/wrapper.dart

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/engine.dart:54:32

   ╷
54 │             final argc = pdata.elementAt(1).value.cast<Int32>().value;
   │                                ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/engine.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.0.0 1.2.1 2.1.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

29
likes
110
pub points
69%
popularity

Publisher

unverified uploader

This plugin is a simple js engine for flutter using the `quickjs` project. Plugin currently supports all the platforms except web!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter

More

Packages that depend on flutter_qjs