flutter_qa 1.1.0+6

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

flutter_qa #

Build Status Coverage Status pub package

Flutter Q&A widgets.

Widgets: #

  • Matching

Demo #

Example #

Demo example project stores data state in global namespace. Advanced example project consumes Redux.

IMPORTANT #

If you have errors about *.g.dart missed files - run following line in terminal:

$ flutter pub run build_runner build

1.1.0+6 #

Simple example added.

1.1.0+4 #

Page class renamed in example to avoid Navigator conflict.

1.1.0+3 #

Fixed last two items swap.

1.1.0+1 #

Some dart analysis and formatting. Draggable test.

1.1.0 #

Ordering widget added.

1.0.0+1 #

Stable.

0.1.0+2 #

Improved example. Column.MainAxis size set to min and matching widget wrapped into Flexible with FlexFit.loose for Slivers.

0.1.0+1 #

qa_matching.dart formatted.

0.1.0 #

  • dart analysis and dartdoc passed

0.0.1+2 #

  • Demo video link.

0.0.1 #

  • Initial release.

example/lib/main.dart

import 'package:flutter/material.dart';

import 'main_page.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  State<StatefulWidget> createState() {
    return MyAppState();
  }
}

class MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) => MaterialApp(
        theme: _buildTheme(),
        home: MainPage(),
      );

  ThemeData _buildTheme() =>
      ThemeData(brightness: Brightness.light, primarySwatch: Colors.blue);
}

//////////////////////////////////////////

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_qa: ^1.1.0+6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_qa/qa_widgets/drag_and_drop_list.dart';
import 'package:flutter_qa/qa_widgets/my_draggable.dart';
import 'package:flutter_qa/qa_widgets/qa_draglist.dart';
import 'package:flutter_qa/qa_widgets/qa_matching.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
flutter 0.0.0
rect_getter ^0.1.0 0.1.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
coverage >=0.13.0 <0.14.0
flutter_test
pedantic >=1.8.0+1 <2.0.0
test >=1.0.0 <2.0.0