flutter_pull_to_refresh 1.0.1
flutter_pull_to_refresh: ^1.0.1 copied to clipboard

Flutter Android iOS

A Flutter package which support pull to refresh and load more.

2
likes
70 / 110
pub points
56 %
popularity

We analyzed this package on Jan 25, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:48:7

   ╷
48 │ <p>微博:<a href="http://weibo.com/payge">@萧雾宇</a></p>
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 39 API elements (25.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_pull_to_refresh/flutter_pull_to_refresh.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_pull_to_refresh.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
70
pub points
56%
popularity

A Flutter package which support pull to refresh and load more.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

xiepeijieapp@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_pull_to_refresh