flutter_pubnub 0.5.0
flutter_pubnub: ^0.5.0 copied to clipboard

A cross platform plugin for creating real time messaging applications with PubNub

14
likes
90 / 130
pub points
73 %
popularity

We analyzed this package on May 14, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 35 out of 103 API elements (34.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_pubnub/generated/i18n.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
uuid^2.0.22.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.2` on uuid does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

14
likes
90
pub points
73%
popularity

A cross platform plugin for creating real time messaging applications with PubNub

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

obrand69@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, uuid

More

Packages that depend on flutter_pubnub