flutter_pod 0.17.0 copy "flutter_pod: ^0.17.0" to clipboard
flutter_pod: ^0.17.0 copied to clipboard

A dependency injection and state management library, fast, simple and composable inspired by Riverpod and Jōtai.

1
likes
130/ 140
pub points
18%
popularity

We analyzed this package 33 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

244 out of 244 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'removeScopedWillPopCallback' is deprecated and shouldn't be used. Use unregisterPopEntry or PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/extension.dart:50:18

   ╷
50 │                 .removeScopedWillPopCallback(callbackWrapper.willPopCallback!);
   │                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/extension.dart

INFO: 'addScopedWillPopCallback' is deprecated and shouldn't be used. Use registerPopEntry or PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/extension.dart:59:20

   ╷
59 │         modalRoute.addScopedWillPopCallback(callbackWrapper.willPopCallback!);
   │                    ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/extension.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
pod ^0.17.0 0.17.0 0.17.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
130
pub points
18%
popularity

Publisher

verified publishereronsoft.com

A dependency injection and state management library, fast, simple and composable inspired by Riverpod and Jōtai.

Homepage
Repository (GitHub)
View/report issues

Topics

#riverpod #pod #atom #dependency-injection #state-management

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, pod

More

Packages that depend on flutter_pod