flutter_plugin_stkouyu 1.0.12 copy "flutter_plugin_stkouyu: ^1.0.12" to clipboard
flutter_plugin_stkouyu: ^1.0.12 copied to clipboard

Flutter plugin for stkouyu.

0
likes
90/ 140
pub points
40%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis http://www.stkouyu.com was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 110 API elements (2.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: KYAudioType, KYAudioType.KYAudioType, KYAudioType.KYAudioType.KYAudioType, KYAudioType.KYAudioType.mp3, KYAudioType.KYAudioType.wav.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:flutter_plugin_stkouyu/flutter_plugin_stkouyu.dart that declares support for platforms: Android, iOS, Windows, macOS.
Package does not support platform `Web`.

Because:

  • package:flutter_plugin_stkouyu/flutter_plugin_stkouyu.dart that declares support for platforms: Android, iOS, Windows, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 33 issues. Showing the first 2:

WARNING: Unused import: 'dart:io'.

lib/flutter_plugin_stkouyu.dart:3:8

  ╷
3 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_plugin_stkouyu.dart

WARNING: Unused import: 'package:flutter_plugin_stkouyu/const/KYCaptureDevice.dart'.

lib/flutter_plugin_stkouyu.dart:8:8

  ╷
8 │ import 'package:flutter_plugin_stkouyu/const/KYCaptureDevice.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_plugin_stkouyu.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.5.0 4.8.1 4.8.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
90
pub points
40%
popularity

Publisher

unverified uploader

Flutter plugin for stkouyu.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, json_annotation

More

Packages that depend on flutter_plugin_stkouyu