flutter_plugin_pdf_viewer 1.0.7
flutter_plugin_pdf_viewer: ^1.0.7 copied to clipboard

Flutter Android iOS

A flutter plugin for handling PDF files. Works on both Android & iOS

54
likes
70 / 110
pub points
94 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 34 API elements (17.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_plugin_pdf_viewer/flutter_plugin_pdf_viewer.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/viewer.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_advanced_networkimage^0.5.00.5.00.7.0
flutter_cache_manager^1.0.01.1.32.1.1
numberpicker^1.0.01.3.01.3.0
path_provider^1.1.01.6.272.0.0
rxdart^0.21.00.21.00.25.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
ffi-0.1.31.0.0
file-5.2.16.1.0
flutter_svg-0.13.10.19.2+1
http-0.12.20.13.0
http_parser-3.1.44.0.0
infinite_listview-1.0.1+11.0.1+1
intl-0.16.10.17.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.0
path_provider_windows-0.0.4+32.0.0
pedantic-1.9.21.10.0
petitparser-3.1.04.0.2
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
sqflite-1.3.2+32.0.0
sqflite_common-1.0.3+12.0.0
string_scanner-1.0.51.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
uuid-2.2.23.0.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0
xml-3.7.05.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.5.0` on flutter_advanced_networkimage does not support the latest published version `0.7.0`

pubspec.yaml:17:34

   ╷
17 │   flutter_advanced_networkimage: ^0.5.0
   │                                  ^^^^^^
   ╵
The constraint `^1.0.0` on flutter_cache_manager does not support the latest published version `2.1.1`

pubspec.yaml:13:26

   ╷
13 │   flutter_cache_manager: ^1.0.0
   │                          ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.