flutter_plugin_engagelab 1.2.1 copy "flutter_plugin_engagelab: ^1.2.1" to clipboard
flutter_plugin_engagelab: ^1.2.1 copied to clipboard

A new Flutter plugin.

0
likes
100/ 140
pub points
79%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
0 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

36 out of 61 API elements (59.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_plugin_engagelab, flutter_plugin_engagelab.EventHandler, flutter_plugin_engagelab.FlutterPluginEngagelab, flutter_plugin_engagelab.FlutterPluginEngagelab.FlutterPluginEngagelab, flutter_plugin_engagelab.FlutterPluginEngagelab.addEventHandler.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_plugin_engagelab/flutter_plugin_engagelab.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_plugin_engagelab/flutter_plugin_engagelab.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_plugin_engagelab/flutter_plugin_engagelab.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_plugin_engagelab/flutter_plugin_engagelab.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Use the generic function type syntax in 'typedef's.

lib/flutter_plugin_engagelab.dart:5:25

  ╷
5 │ typedef Future<dynamic> EventHandler(Map<String, dynamic> event);
  │                         ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_plugin_engagelab.dart

lib/flutter_plugin_engagelab.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
100
pub points
79%
popularity

Publisher

unverified uploader

A new Flutter plugin.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_plugin_engagelab