flutter_pin_code 1.0.1
flutter_pin_code: ^1.0.1 copied to clipboard

A simple Flutter widget for entering pin code using materials design.

0
likes
70 / 130
pub points
43 %
popularity

We analyzed this package on May 14, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 17 API elements (5.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_pin_code/flutter_pin_code.dart that imports:
  • package:flutter_pin_code/src/pin_code_view.dart that imports:
  • package:flutter_pin_code/src/single_pin_view.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/pin_code_view.dart:182:12

    ╷
182 │     return FlatButton(
    │            ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/pin_code_view.dart

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/pin_code_view.dart:202:12

    ╷
202 │     return FlatButton(
    │            ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/pin_code_view.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.15.00.15.07.0.0
equatable^0.5.10.5.12.0.0
flutterflutter0.0.00.0.0
flutter_bloc^0.21.00.21.07.0.0
flutter_screenutil^0.6.00.6.15.0.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
provider-3.2.05.0.0
rxdart-0.22.60.27.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.15.0` on bloc does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^0.5.1` on equatable does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

0
likes
70
pub points
43%
popularity

A simple Flutter widget for entering pin code using materials design.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

rinlv.hn@gmail.com

License

LICENSE

Dependencies

bloc, equatable, flutter, flutter_bloc, flutter_screenutil

More

Packages that depend on flutter_pin_code