flutter_persistent_queue 6.1.1+1
flutter_persistent_queue: ^6.1.1+1 copied to clipboard

Flutter Android iOS web

Simple file-based non-volatile persistent queue implementation for flutter. Ideal for in-device sequential buffers that must persist between app runs.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_persistent_queue: ^6.1.1+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_persistent_queue/flutter_persistent_queue.dart';
6
likes
100
pub points
78%
popularity

Simple file-based non-volatile persistent queue implementation for flutter. Ideal for in-device sequential buffers that must persist between app runs.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

oakromulo@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, localstorage

More

Packages that depend on flutter_persistent_queue