flutter_overlay_kit 0.0.4 copy "flutter_overlay_kit: ^0.0.4" to clipboard
flutter_overlay_kit: ^0.0.4 copied to clipboard

Platformweb

toast + alert + actionsheet.

0
likes
115/ 160
pub points
1%
popularity

We analyzed this package 34 hours ago, and awarded it 115 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

24 out of 234 API elements (10.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: actionsheet, actionsheet.ActionSheetWidget, actionsheet.ActionSheetWidget.ActionSheetWidget, actionsheet.ActionSheetWidget.currentSelectedIndex, actionsheet.ActionSheetWidget.itemTitles.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_overlay_kit/flutter_overlay_kit.dart that imports:
  • package:flutter_overlay_kit/toast/toast_util.dart that imports:
  • package:toast/toast.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:flutter_overlay_kit/flutter_overlay_kit.dart that imports:
  • package:flutter_overlay_kit/toast/toast_util.dart that imports:
  • package:toast/toast.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:flutter_overlay_kit/flutter_overlay_kit.dart that imports:
  • package:flutter_overlay_kit/toast/toast.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_overlay_kit/flutter_overlay_kit.dart that imports:
  • package:flutter_overlay_kit/toast/toast.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_overlay_kit/flutter_overlay_kit.dart that imports:
  • package:flutter_overlay_kit/toast/toast.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The file name 'showModal_util.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/actionsheet/action/showModal_util.dart

INFO: 'MediaQueryData.fromWindow' is deprecated and shouldn't be used. Use MediaQueryData.fromView instead. This constructor was deprecated in preparation for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/actionsheet/components/actionsheet_footer.dart:50:9

   ╷
50 │         MediaQueryData.fromWindow(window); // 需 import 'dart:ui';
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/actionsheet/components/actionsheet_footer.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_baseui_kit ^0.0.4 0.0.4 0.0.4
fluttertoast ^8.2.1 8.2.6 8.2.6
synchronized ^3.0.0+2 3.1.0+1 3.1.0+1
toast ^0.3.0 0.3.0 0.3.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.