flutter_otp_text_field 1.0.0
flutter_otp_text_field: ^1.0.0 copied to clipboard

Fully customizable OTP Entry TextField for flutter, Widget accepts pin of any length. Its written in pure dart, no extra dependency.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_otp_text_field

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  flutter_otp_text_field: ^1.0.0

Alternatively, your editor might support or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_otp_text_field/flutter_otp_text_field.dart';
16
likes
120
pub points
91%
popularity

Fully customizable OTP Entry TextField for flutter, Widget accepts pin of any length. Its written in pure dart, no extra dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_otp_text_field