flutter_octicons 0.7.0 icon indicating copy to clipboard operation
flutter_octicons: ^0.7.0 copied to clipboard

Easily integrate GitHub's Octicons in your own Flutter project.

Flutter Octicons

GitHub's octicons for your Flutter app

image

About #

This Dart package allows you to use Octicon icons developed by GitHub and released under the MIT license in Flutter.

flutter_octicons automatically updates itself every night to always stay up to date with the upstream Octicons project.

Usage #

import 'package:flutter_octicons/flutter_octicons.dart';

Icon(OctIcons.telescope_fill_24);

Please note that all icons included in this package are of the same size when used as above (set to the default provided by IconTheme), which is usually 24. To correctly set the size for e.g. Octicons of size 16, please provide the following argument:

Icon(OctIcons.telescope_fill_16, size: 16);

Octicons list #

For a full list of all Octicons see here

Rolling updates #

The motivation for me to create this package was that octicons_icon has not been updated in a long time.

This library automatically avoids becoming stale by rolling in the newest icons changes from the upstream Octicons repository every night.

To comply with the versioning imposed by dart, the minor version always increases by 1 for each update (major.MINOR.patch). You can either specify any as your version constraint to always live at head or remember to update the version once new icons become available.

Why the minor version?
Because new versions may be breaking for you, icons could be changed or completely deleted.

Credits #

This package (especially the automation) would not be possible without these awesome projects:

License #

BSD 3-Clause “New” or “Revised” License

2
likes
120
pub points
58%
popularity

Publisher

verified publisher iconrubinraithel.de

Easily integrate GitHub's Octicons in your own Flutter project.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_octicons