flutter_observable_state 1.3.0
flutter_observable_state: ^1.3.0 copied to clipboard

Simple and powerful state management for Flutter applications. With minimal boilerplate, stream support and computed state

8
likes
80 / 130
pub points
64 %
popularity

We analyzed this package on May 14, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 30 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The value of the local variable 'observer' isn't used.

lib/flutter_observable_state.dart:167:13

    ╷
167 │       final observer = currentObserver;
    │             ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_observable_state.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.24.10.24.10.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.24.1` on rxdart does not support the stable version `0.25.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

8
likes
80
pub points
64%
popularity

Simple and powerful state management for Flutter applications. With minimal boilerplate, stream support and computed state

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

christianalfoni@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on flutter_observable_state