flutter_mongo_stitch_web 0.2.0+a

  • Readme
  • Changelog
  • Installing
  • new63

flutter_mongo_stitch_web #

The web implementation of flutter_mongo_stitch

Usage #

Import the package #

This package is the endorsed implementation of flutter_mongo_stitch for the web platform since version 0.7.1, so it gets automatically added to your dependencies by depending on flutter_mongo_stitch: ^0.7.1.

No modifications to your pubspec.yaml should be required in a recent enough version of Flutter (>=1.12.13+hotfix.4):

...
dependencies:
  ...
  flutter_mongo_stitch: ^0.7.1
  ...
...

Web integration #

From version 0.2.0, it's done under the hood :)

[0.2.0] #

  • js library are injected throw dart

[0.1.1] #

  • Fixed bugs

[0.1.0] #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_mongo_stitch_web: ^0.2.0+a

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart] that declares support for platforms: web

Package does not support Flutter platform ios

Because of import path [package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart] that declares support for platforms: web

Package does not support Flutter platform linux

Because of import path [package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart] that declares support for platforms: web

Package does not support Flutter platform macos

Because of import path [package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart] that declares support for platforms: web

Package does not support Flutter platform windows

Because of import path [package:flutter_mongo_stitch_web/flutter_mongo_stitch_web.dart] that declares support for platforms: web

Package not compatible with SDK dart

because of import path [flutter_mongo_stitch_web] that is in a package requiring null.

Health suggestions

Format lib/flutter_mongo_stitch_web.dart.

Run flutter format to format lib/flutter_mongo_stitch_web.dart.

Format lib/src/interop.dart.

Run flutter format to format lib/src/interop.dart.

Format lib/src/utils.dart.

Run flutter format to format lib/src/utils.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_mongo_stitch_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
flutter_mongo_stitch_platform_interface ^1.0.0 1.0.0+a
flutter_web_plugins 0.0.0
js ^0.6.2 0.6.2
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
plugin_platform_interface 1.0.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test