flutter_mongo_stitch_platform_interface 2.2.1 copy "flutter_mongo_stitch_platform_interface: ^2.2.1" to clipboard
flutter_mongo_stitch_platform_interface: ^2.2.1 copied to clipboard

A common platform interface for the flutter_mongodb_realm plugin.

flutter_mongo_stitch_platform_interface #

A common platform interface for the flutter_mongo_stitch plugin.

This interface allows platform-specific implementations of the flutter_mongo_stitch plugin, as well as the plugin itself, to ensure they are supporting the same interface.

Usage #

To implement a new platform-specific implementation of flutter_mongo_stitch, extend FlutterMongoStitchPlatform with an implementation that performs the platform-specific behavior, and when you register your plugin, set the default FlutterMongoStitchPlatform by calling FlutterMongoStitchPlatform.instance = MyFlutterMongoStitchPlatformLauncher().

Note on breaking changes #

Strongly prefer non-breaking changes (such as adding a method to the interface) over breaking changes for this package.

See https://flutter.dev/go/platform-interface-breaking-changes for a discussion on why a less-clean interface is preferable to a breaking change.

0
likes
120
pub points
28%
popularity

Publisher

verified publishermatiapps.com

A common platform interface for the flutter_mongodb_realm plugin.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on flutter_mongo_stitch_platform_interface