flutter_mobx_helpers 1.0.1
flutter_mobx_helpers: ^1.0.1 copied to clipboard

A set of tools for MobX that helps you with common processes making everything easier.

19
likes
90 / 110
pub points
77 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 7 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Don't import implementation files from another package.

lib/src/observer_listener.dart:3:8

  ╷
3 │ import 'package:mobx/src/core.dart' show ReactionImpl;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/observer_listener.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
mobx>=1.0.0 <2.0.01.2.1+42.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=1.0.0 <2.0.0` on mobx does not support the stable version `2.0.0`, that was published 11 days ago.

When mobx is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions mobx to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

19
likes
90
pub points
77%
popularity

A set of tools for MobX that helps you with common processes making everything easier.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jacobaraujo7@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, mobx

More

Packages that depend on flutter_mobx_helpers