flutter_mixin_router_gen 1.0.5 copy "flutter_mixin_router_gen: ^1.0.5" to clipboard
flutter_mixin_router_gen: ^1.0.5 copied to clipboard

Code generator for flutter_mixin_router that adds support for annotating your code with @MixinRoute, @MixinInterceptRoute, @RouterTableList.

3
likes
35/ 140
pub points
15%
popularity

We analyzed this package 2 days ago, and awarded it 35 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
Because every version of flutter_mixin_router_ann depends on flutter from sdk which doesn't exist (could not find package flutter in the Flutter SDK), flutter_mixin_router_ann is forbidden.
So, because flutter_mixin_router_gen depends on flutter_mixin_router_ann ^1.0.2, version solving failed.
failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because every version of flutter_mixin_router_ann depends on flutter from sdk which doesn't exist (could not find package flutter in the Flutter SDK), flutter_mixin_router_ann is forbidden.
So, because flutter_mixin_router_gen depends on flutter_mixin_router_ann ^1.0.2, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

3
likes
35
pub points
15%
popularity

Publisher

verified publisheriflutter.toolu.cn

Code generator for flutter_mixin_router that adds support for annotating your code with @MixinRoute, @MixinInterceptRoute, @RouterTableList.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

analyzer, build, flutter_mixin_router_ann, source_gen

More

Packages that depend on flutter_mixin_router_gen