flutter_media_streamer 1.0.2
flutter_media_streamer: ^1.0.2 copied to clipboard

A Flutter plugin for streaming Media on iOS and Android. Reads Images metadata from the Platform's Gallery as a dart Stream Resizes and gets the images you want or makes Thumbnails

2
likes
90 / 130
pub points
21 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 124 out of 515 API elements (24.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_media_streamer/flutter_media_streamer.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.3.24.3.25.1.0
built_value^7.1.07.1.08.0.6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
fixnum-0.10.111.0.0
matcher-0.12.100.12.10
meta-1.3.01.4.0
path-1.8.01.8.0
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.3.2` on built_collection does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

The constraint `^7.1.0` on built_value does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions built_value to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

2
likes
90
pub points
21%
popularity

Publisher

guyor.net

A Flutter plugin for streaming Media on iOS and Android. Reads Images metadata from the Platform's Gallery as a dart Stream Resizes and gets the images you want or makes Thumbnails

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

built_collection, built_value, flutter

More

Packages that depend on flutter_media_streamer