flutter_love_provider 0.1.0 copy "flutter_love_provider: ^0.1.0" to clipboard
flutter_love_provider: ^0.1.0 copied to clipboard

Provide flutter widgets for supporting solution base on flutter, love and provider.

0
likes
120/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

201 out of 249 API elements (80.7 %) have documentation comments.

Some symbols that are missing documentation: flutter_love_provider, flutter_love_provider.CopyRun, flutter_love_provider.Dispatch.call, flutter_love_provider.DispatchX, flutter_love_provider.Disposer.call.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/flutter_love_provider.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/dispatch_x.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_love ^0.2.0 0.2.0 0.2.0
love ^0.2.0 0.2.0 0.2.0
nested ^1.0.0 1.0.0 1.0.0
provider ^6.0.0 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
typedef_equals - 0.0.1 0.2.0
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Provide flutter widgets for supporting solution base on flutter, love and provider.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_love, love, nested, provider

More

Packages that depend on flutter_love_provider