flutter_localized_countries 1.0.0
flutter_localized_countries: ^1.0.0 copied to clipboard

Country code to name mappings for several languages

4
likes
20 / 110
pub points
68 %
popularity

We analyzed this package on Apr 21, 2021, and awarded it 20 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...
stderr: IO  : Get versions from https://pub.dartlang.org/api/packages/intl.
IO  : HTTP GET https://pub.dartlang.org/api/packages/intl
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.12.2
IO  : HTTP response 200 OK for GET https://pub.dartlang.org/api/packages/intl
    | took 0:00:00.139797
    | transfer-encoding: chunked
    | date: Tue, 20 Apr 2021 15:01:36 GMT
    | content-encoding: gzip
    | vary: Accept-Encoding
    | strict-transport-security: max-age=31536000; preload
    | via: 1.1 google
    | content-type: application/json; charset="utf-8"
    | x-frame-options: SAMEORIGIN
    | x-xss-protection: 1; mode=block
    | x-content-type-options: nosniff
    | server: dart:io with Shelf
IO  : Writing 104722 characters to text file /tmp/tool-envLTCVEE/pub-cache-dirSNOPWU/hosted/pub.dartlang.org/.cache/intl-versions.json.
IO  : Get versions from https://pub.dartlang.org/api/packages/clock.
IO  : Get versions from https://pub.dartlang.org/api/packages/path.
IO  : HTTP GET https://pub.dartlang.org/api/packages/clock
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.12.2
IO  : HTTP GET https://pub.dartlang.org/api/packages/path
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.12.2
ERR : Because flutter_localized_countries depends on flutter_localizations any from sdk which depends on intl 0.17.0, intl 0.17.0 is required.
    | So, because flutter_localized_countries depends on intl ^0.15.7, version solving failed.
pub finished with exit code 1
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/flutter_localized_countries.dart:4:8

  ╷
4 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_localized_countries.dart

ERROR: Target of URI doesn't exist: 'package:flutter/services.dart'.

lib/flutter_localized_countries.dart:5:8

  ╷
5 │ import 'package:flutter/services.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_localized_countries.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because flutter_localized_countries depends on flutter_localizations any from sdk which depends on intl 0.17.0, intl 0.17.0 is required.
So, because flutter_localized_countries depends on intl ^0.15.7, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.