flutter_live 1.0.16 copy "flutter_live: ^1.0.16" to clipboard
flutter_live: ^1.0.16 copied to clipboard

Live streaming player, iOS+Android, RTMP/HTTP-FLV/HLS/WebRTC, by Flutter+SRS.

36
likes
40/ 140
pub points
52%
popularity

We analyzed this package 3 hours ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.1. Cannot run `flutter pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.1.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.1)

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

36
likes
40
pub points
52%
popularity

Publisher

verified publisherossrs.net

Live streaming player, iOS+Android, RTMP/HTTP-FLV/HLS/WebRTC, by Flutter+SRS.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

camera_with_rtmp, fijkplayer, flutter, flutter_webrtc

More

Packages that depend on flutter_live