flutter_list_bloc 0.0.2

  • Readme
  • Changelog
  • Installing
  • new44

flutter_list_bloc #

This is very much work in progress prototype, for the time being it should be considered as an example of using list_bloc in flutter

Features and bugs #

Please file feature requests and bugs at the issue tracker.

[0.0.2] - 23 Jun 2020 #

  • Different approach to building pages

[0.0.1] - 23 Jun 2020 #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_list_bloc: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_list_bloc/flutter_list_bloc.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart


  • flutter_list_bloc that is a package requiring null.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_bloc).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_list_bloc.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
flutter_bloc ^4.0.0 4.0.1 5.0.1
list_bloc ^0.0.5 0.0.5
Transitive dependencies
bloc 4.0.0 5.0.1
collection 1.14.12 1.14.13
equatable 1.2.2
meta 1.1.8 1.2.2
nested 0.0.4
provider 4.3.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies