flutter_lints 4.0.0 copy "flutter_lints: ^4.0.0" to clipboard
flutter_lints: ^4.0.0 copied to clipboard

Recommended lints for Flutter apps, packages, and plugins to encourage good coding practices.

4.0.0 #

  • Updates package:lints dependency to version 4.0.0, with the following changes:
    • adds library_annotations
    • adds no_wildcard_variable_uses
    • removes package_prefixed_library_names
    • removes library_names

3.0.2 #

  • Updates minimum supported SDK version to Flutter 3.13/Dart 3.1.
  • Updates various links in comments and documentation.

3.0.1 #

  • Replaces flutter pub add --dev with dev: in README.md.

3.0.0 #

  • Updated package:lints dependency to version 3.0.0, with the following changes:
    • added collection_methods_unrelated_type
    • added dangling_library_doc_comments
    • added implicit_call_tearoffs
    • added secure_pubspec_urls
    • added type_literal_in_constant_pattern
    • added unnecessary_to_list_in_spreads
    • added use_string_in_part_of_directives
    • added use_super_parameters
    • removed iterable_contains_unrelated_type
    • removed list_remove_unrelated_type
    • removed no_wildcard_variable_uses
    • removed prefer_equal_for_default_values
    • removed prefer_void_to_null
  • Updates minimum supported SDK version to Flutter 3.10 / Dart 3.0.

2.0.3 #

  • Adds pub topics to package metadata.
  • Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.

2.0.2 #

  • Update links to the old linter site in the README and example to point to dart.dev.
  • Updates minimum supported SDK version to Flutter 3.3/Dart 2.18.

2.0.1 #

  • Updated readme to document suggestion process for new lints

2.0.0 #

  • Added the following lints:
    • sort_child_properties_last
    • use_build_context_synchronously
  • Updated package:lints dependency to version 2.0.0, which added the following lints:
    • depend_on_referenced_packages
    • library_private_types_in_public_api
    • no_leading_underscores_for_library_prefixes
    • no_leading_underscores_for_local_identifiers
    • null_check_on_nullable_type_parameter
    • prefer_interpolation_to_compose_strings
    • unnecessary_constructor_name
    • unnecessary_late
    • unnecessary_null_aware_assignments
    • unnecessary_nullable_for_final_variable_declarations
  • Bumped the minimum required Dart SDK version to 2.17

1.0.4 #

  • Small update to readme

1.0.3 #

  • More small updates to readme

1.0.2 #

  • Small updates to readme

1.0.1 #

  • Added an example project

1.0.0 #

  • Initial release
1104
likes
160
pub points
100%
popularity

Publisher

verified publisherflutter.dev

Recommended lints for Flutter apps, packages, and plugins to encourage good coding practices.

Repository (GitHub)
View/report issues
Contributing

Topics

#lints

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

lints

More

Packages that depend on flutter_lints