flutter_kz_library 0.1.3
flutter_kz_library: ^0.1.3 copied to clipboard

reusable function in flutter such as dio http, widgets, redux......

1
likes
40 / 130
pub points
0 %
popularity

We analyzed this package on May 10, 2021, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/WMaximusW/Flutter_Kz_Library was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 28 out of 305 API elements (9.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_kz_library/flutter_kz_library.dart that imports:
  • package:flutter_kz_library/src/widgets/Widget.dart that imports:
  • package:flutter_kz_library/src/widgets/forms/InputWidget.dart that imports:
  • package:flutter_form_builder/flutter_form_builder.dart that imports:
  • package:flutter_form_builder/src/fields/form_builder_phone_field.dart that imports:
  • package:phone_number/phone_number.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

ERROR: The named parameter 'autovalidate' isn't defined.

lib/src/widgets/forms/FormWidget.dart:18:7

   ╷
18 │       autovalidate: autoValidate,
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/widgets/forms/FormWidget.dart

INFO: Unused import: 'package:flutter_kz_library/flutter_kz_library.dart'.

lib/src/statics/Statics.dart:4:8

  ╷
4 │ import 'package:flutter_kz_library/flutter_kz_library.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/statics/Statics.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bottom_navy_bar^5.3.25.6.06.0.0
bubble_bottom_bar^1.2.01.2.01.2.0
carousel_slider^1.4.11.4.13.0.0
dio^3.0.93.0.104.0.0
file_picker^1.5.11.13.33.0.1
flutterflutter0.0.00.0.0
flutter_form_builder^3.8.13.14.16.0.0
flutter_pagewise^1.2.31.2.32.0.1
flutter_redux^0.6.00.6.00.8.2
flutter_speed_dial^1.2.51.2.53.0.5
intl^0.16.10.16.10.17.0
path^1.6.41.8.01.8.0
progress_dialog^1.2.11.2.41.2.4
redux^4.0.04.0.0+35.0.0
rflutter_alert^1.0.31.1.02.0.2
sqflite^1.3.01.3.2+42.0.0+3
toast^0.1.50.1.50.1.5
url_launcher^5.4.25.7.106.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.0
async-2.6.12.6.1
basic_utils-2.7.13.0.2
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
country_pickers-1.3.02.0.0
crypto-2.1.53.0.1
date_range_picker-1.0.71.0.7
datetime_picker_formfield-1.0.02.0.0
file_picker_platform_interface-1.3.12.0.0
flutter_chips_input-1.9.51.9.5
flutter_colorpicker-0.3.50.4.0
flutter_keyboard_visibility-4.0.65.0.1
flutter_keyboard_visibility_platform_interface-1.0.12.0.0
flutter_keyboard_visibility_web-1.0.12.0.0
flutter_plugin_android_lifecycle-1.0.112.0.1
flutter_touch_spin-1.0.11.0.1
flutter_typeahead-1.9.33.1.3
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
image-2.1.193.0.2
image_picker-0.6.7+220.7.4
image_picker_for_web-0.1.0+22.0.0
image_picker_platform_interface-1.1.62.1.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
logging-0.11.41.0.1
meta-1.3.01.3.0
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
phone_number-0.6.30.10.0
plugin_platform_interface-1.0.32.0.0
pointycastle-2.0.13.0.1
random_string-2.1.02.1.0
rating_bar-0.2.00.2.0
signature-3.2.14.1.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.0+2
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.2
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
validators-2.0.13.0.0
vector_math-2.1.02.1.0
vin_decoder-0.1.30.1.3
xml-4.5.15.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 13 issues. Showing the first 2:

The constraint `^5.3.2` on bottom_navy_bar does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions bottom_navy_bar to update the constraint.

The constraint `^1.4.1` on carousel_slider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions carousel_slider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.