flutter_jsettings 0.1.0 copy "flutter_jsettings: ^0.1.0" to clipboard
flutter_jsettings: ^0.1.0 copied to clipboard

JSON settings

4
likes
120/ 140
pub points
33%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/ubuntu-flutter-community/jsettings.dart was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/ubuntu-flutter-community/jsettings.dart was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/ubuntu-flutter-community/jsettings.dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_jsettings,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 36 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_jsettings.JSettings, flutter_jsettings.JSettings.JSettings, flutter_jsettings.JSettings.added, flutter_jsettings.JSettings.changed, flutter_jsettings.JSettings.close.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_jsettings/flutter_jsettings.dart that imports:
  • package:flutter_jsettings/src/jsettings_notifier.dart that imports:
  • package:jsettings/jsettings.dart that imports:
  • package:jsettings/src/jsettings_x.dart that imports:
  • package:jsettings/src/jsettings.dart that imports:
  • package:jsettings/src/jsettings_file.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
jsettings ^0.1.1 0.1.1 0.1.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.