flutter_indzooom_pdf_viewer 1.0.8

Flutter Android iOS

A flutter plugin for handling PDF files. Works on both Android & iOS

1
likes
60 / 110
pub points
42 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/giulianojordao/flutter_indzooom_pdf_viewer was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 34 API elements (17.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that imports:
  • package:flutter_indzooom_pdf_viewer/src/document.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:flutter_indzooom_pdf_viewer/flutter_indzooom_pdf_viewer.dart that imports:
  • package:flutter_indzooom_pdf_viewer/src/document.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/viewer.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_advanced_networkimage^0.5.00.5.00.7.0
flutter_cache_manager^1.0.01.1.32.0.0
numberpicker^1.0.01.2.11.2.1
path_provider^1.1.01.6.221.6.22
rxdart^0.21.00.21.00.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_svg-0.13.10.19.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
infinite_listview-1.0.1+11.0.1+1
intl-0.16.10.16.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
path-1.7.01.7.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
sqflite-1.3.1+21.3.1+2
sqflite_common-1.0.2+11.0.2+1
string_scanner-1.0.51.0.5
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xml-3.7.04.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.5.0` on flutter_advanced_networkimage does not support the latest published version `0.7.0`

pubspec.yaml:17:34

   ╷
17 │   flutter_advanced_networkimage: ^0.5.0
   │                                  ^^^^^^
   ╵
The constraint `^1.0.0` on flutter_cache_manager does not support the latest published version `2.0.0`

pubspec.yaml:13:26

   ╷
13 │   flutter_cache_manager: ^1.0.0
   │                          ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs