flutter_iiif 0.1.1+1

flutter_iiif #

A flutter implementation for IIIF images.

Find more information on IIIF here: IIIF specs

Basic usage: #

In your pubspec.yaml:

dependencies:
  flutter:
    sdk: flutter
  flutter_iiif:^0.0.1

import:

import 'package:flutter_iiif/flutter_iiif.dart';

Add the following code to your widget-tree:

IIIFImage(
    settings:IIIFImageSettings(
        server: 'http://your_iiif_server/', 
        assetID: 'filname_or_assetID', 
        quality: '[default|gray|color].[jpg|png|etc]'
     )
);

Demo #

Flutter IIIF Demo

Check out the example folder.

Repository #

https://code.naturkundemuseum.berlin/naturkunde_365_24/flutter_iiif

Pub #

https://pub.dev/packages/flutter_iiif

[0.1.1+1]

  • updated faulty preview image url

[0.1.1] - Public Repository

[0.1.0] - Initial Public Release

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_iiif: ^0.1.1+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_iiif/flutter_iiif.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Aug 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
http ^0.12.0 0.12.0+2
vector_math ^2.0.0 2.0.8
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.4
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
flutter_test
test ^1.3.0