flutter_i18n 0.22.1 copy "flutter_i18n: ^0.22.1" to clipboard
flutter_i18n: ^0.22.1 copied to clipboard

outdated

i18n made easy for Flutter. With flutter_i18n you can make your app international, using just a simple .json file!

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_i18n

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  flutter_i18n: ^0.22.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_i18n/flutter_i18n.dart';
192
likes
0
pub points
97%
popularity

Publisher

unverified uploader

i18n made easy for Flutter. With flutter_i18n you can make your app international, using just a simple .json file!

Repository (GitHub)
View/report issues

License

unknown (license)

Dependencies

flutter, flutter_localizations, flutter_web_plugins, intl, path, xml2json, yaml

More

Packages that depend on flutter_i18n