flutter_hls_audio_player_platform_interface 0.0.1
flutter_hls_audio_player_platform_interface: ^0.0.1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A common platform interface for the url_launcher plugin.

0
likes
60 / 110
pub points
12 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://guruprasath.dev was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 16 API elements (18.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_hls_audio_player_platform_interface.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/method_channel_url_launcher.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.51.3.0-nullsafety.31.3.0
plugin_platform_interface^1.0.11.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on plugin_platform_interface does not support the latest published version `2.0.0`

pubspec.yaml:12:30

   ╷
12 │   plugin_platform_interface: ^1.0.1
   │                              ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

0
likes
60
pub points
12%
popularity

A common platform interface for the url_launcher plugin.

Homepage

Documentation

API reference

Uploader

freelance@guruprasath.dev

License

BSD (LICENSE.md)

Dependencies

flutter, meta, plugin_platform_interface

More

Packages that depend on flutter_hls_audio_player_platform_interface