flutter_hls_audio_player 0.2.0
flutter_hls_audio_player: ^0.2.0 copied to clipboard

Flutter Android iOS web

This plugin streams audio from hls url works on both iOS and Android.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_hls_audio_player: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_hls_audio_player/audio.dart';
import 'package:flutter_hls_audio_player/player_state.dart';
import 'package:flutter_hls_audio_player/video.dart';
import 'package:flutter_hls_audio_player/player_observer.dart';
0
likes
80
pub points
0%
popularity

Publisher

guruprasath.dev

This plugin streams audio from hls url works on both iOS and Android.

Homepage

Documentation

API reference

License

BSD (LICENSE.md)

Dependencies

flutter, flutter_hls_audio_player_platform_interface, flutter_hls_audio_player_web, flutter_web_plugins

More

Packages that depend on flutter_hls_audio_player