flutter_hls_audio_player_web 0.0.1

  • Readme
  • Changelog
  • Installing
  • 69

flutter_hls_audio_player #

Flutter library for streaming hls audio.Supports both ios and android.

0.0.1 #

  • initital version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_hls_audio_player_web: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Android

Because:

  • package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart that declares support for platforms: Web

Package does not support Flutter platform Linux

Because:

  • package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart that declares support for platforms: Web

Package does not support Flutter platform Windows

Because:

  • package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart that declares support for platforms: Web

Package does not support Flutter platform iOS

Because:

  • package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart that declares support for platforms: Web

Package does not support Flutter platform macOS

Because:

  • package:flutter_hls_audio_player_web/flutter_hls_audio_player_web.dart that declares support for platforms: Web

Package not compatible with SDK dart

Because:

  • flutter_hls_audio_player_web that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_hls_audio_player_web.dart.

Run flutter format to format lib/flutter_hls_audio_player_web.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_hls_audio_player_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
flutter_hls_audio_player_platform_interface ^0.0.1 0.0.1
flutter_web_plugins 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
plugin_platform_interface 1.0.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety