flutter_health 1.2.12
flutter_health: ^1.2.12 copied to clipboard

Flutter Android iOS

This library combines both GoogleFit and AppleHealthKit. It support most of the values provided.

9
likes
80 / 110
pub points
60 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 133 API elements (4.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_health/flutter_health.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The stack trace variable 's' isn't used and can be removed.

lib/flutter_health.dart:171:17

    ╷
171 │     } catch (e, s) {
    │                 ^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_health.dart

lib/flutter_health.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

9
likes
80
pub points
60%
popularity

This library combines both GoogleFit and AppleHealthKit. It support most of the values provided.

Repository (GitLab)
View/report issues

Documentation

API reference

Uploaders

buelent.hacioglu@petleo.net
karim.abdo%petleo.net@gtempaccount.com
google@i-atros.com
patrick.palacin.de@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_health