flutter_gen_core 3.1.1
flutter_gen_core: ^3.1.1 copied to clipboard

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

1
likes
100 / 130
pub points
88 %
popularity

We analyzed this package on May 17, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 344 out of 713 API elements (48.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_gen_core/flutter_generator.dart that imports:
  • package:flutter_gen_core/utils/file.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: 'flutterGen' is deprecated and shouldn't be used. Access from pubspec.

lib/flutter_generator.dart:38:27

   ╷
38 │     final output = config.flutterGen.output;
   │                           ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flutter_generator.dart

INFO: 'flutterGen' is deprecated and shouldn't be used. Access from pubspec.

lib/flutter_generator.dart:39:31

   ╷
39 │     final lineLength = config.flutterGen.lineLength;
   │                               ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flutter_generator.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=1.0.0 <2.0.01.5.01.5.0
args>=2.0.0 <3.0.02.1.02.1.0
collection>=1.15.0 <2.0.01.15.01.15.0
color>=3.0.0 <4.0.03.0.03.0.0
dartx>=0.6.0 <1.0.00.7.10.7.1
json_annotation>=4.0.0 <5.0.04.0.14.0.1
mime>=1.0.0 <2.0.01.0.01.0.0
path>=1.7.0 <2.0.01.8.01.8.0
pub_semver>=1.4.0 <3.0.02.0.02.0.0
source_span>=1.6.0 <2.0.01.8.11.8.1
xml>=5.0.0 <6.0.05.1.05.1.0
yaml>=3.0.0 <4.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-21.0.021.0.0
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-6.1.16.1.1
glob-2.0.12.0.1
meta-1.3.01.3.0
package_config-2.0.02.0.0
pedantic-1.11.01.11.0
petitparser-4.1.04.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
time-2.0.02.0.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

1
likes
100
pub points
88%
popularity

Publisher

wasabeef.jp

The Flutter code generator for your assets, fonts, colors, … — Get rid of all String-based APIs.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

analyzer, args, collection, color, dartx, json_annotation, mime, path, pub_semver, source_span, xml, yaml

More

Packages that depend on flutter_gen_core