flutter_gadgets_2 0.3.0 copy "flutter_gadgets_2: ^0.3.0" to clipboard
flutter_gadgets_2: ^0.3.0 copied to clipboard

Flutter Gadgets 2, a library for simplified state (model) management and service location in Flutter.

12
likes
130/ 140
pub points
34%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

28 out of 54 API elements (51.9 %) have documentation comments.

Some symbols that are missing documentation: flutter_gadgets_2, flutter_gadgets_2.AppGadget.dispose, flutter_gadgets_2.AppGadget.init, flutter_gadgets_2.ControllerGadget.context, flutter_gadgets_2.ControllerGadget.contextGetter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The null check operator shouldn't be used on a variable whose type is a potentially nullable type parameter.

lib/src/subscriber_gadget.dart:103:73

    ╷
103 │       _currentPropertiesState = widget.propertiesSelector!(_currentValue!);
    │                                                                         ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/subscriber_gadget.dart

INFO: The null check operator shouldn't be used on a variable whose type is a potentially nullable type parameter.

lib/src/subscriber_gadget.dart:144:49

    ╷
144 │     return widget.builder(context, _currentValue!);
    │                                                 ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/subscriber_gadget.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
provider ^6.0.1 6.1.2 6.1.2
rxdart ^0.27.2 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

12
likes
130
pub points
34%
popularity

Publisher

verified publishersvelto.tech

Flutter Gadgets 2, a library for simplified state (model) management and service location in Flutter.

Repository

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter, provider, rxdart

More

Packages that depend on flutter_gadgets_2