flutter_full_pdf_viewer 1.0.6
flutter_full_pdf_viewer: ^1.0.6 copied to clipboard

A flutter plugin to display PDF. This works for Android and for iOS.

110
likes
90 / 130
pub points
96 %
popularity

We analyzed this package on May 4, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 27 API elements (25.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_full_pdf_viewer/flutter_full_pdf_viewer.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_full_pdf_viewer.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/full_pdf_viewer_scaffold.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

110
likes
90
pub points
96%
popularity

A flutter plugin to display PDF. This works for Android and for iOS.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alveliu93@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_full_pdf_viewer