flutter_form_builder 4.0.1
flutter_form_builder: ^4.0.1

Flutter Android iOS

This package helps in creation of forms in Flutter by removing the boilerplate code, reusing validation, react to changes, and collect final user input.

480
likes
100 / 110
pub points
97 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 408 out of 784 API elements (52.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_form_builder/flutter_form_builder.dart that imports:
  • package:flutter_form_builder/src/fields/form_builder_typeahead.dart that imports:
  • package:flutter_typeahead/flutter_typeahead.dart that imports:
  • package:flutter_keyboard_visibility/flutter_keyboard_visibility.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
community_material_icon^5.4.555.4.555.4.55
country_pickers^1.3.01.3.01.3.0
date_range_picker^1.0.61.0.61.0.6
datetime_picker_formfield^1.0.01.0.01.0.0
dropdown_search^0.4.80.4.80.4.8
file_picker^2.1.02.1.02.1.0
flutter_chips_input^1.9.41.9.41.9.4
flutter_colorpicker^0.3.40.3.40.3.4
flutter_datetime_picker^1.4.01.4.01.4.0
flutter_touch_spin^1.0.11.0.11.0.1
flutter_typeahead^1.8.81.8.81.8.8
image_picker^0.6.7+140.6.7+140.6.7+14
image_picker_for_web^0.1.0+20.1.0+20.1.0+2
intl^0.16.10.16.10.16.1
permission_handler^5.0.1+15.0.1+15.0.1+1
phone_number^0.8.10.8.10.8.1
rating_bar^0.2.00.2.00.2.0
signature^3.2.03.2.03.2.0
validators^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
asn1lib-0.6.50.8.1
basic_utils-2.6.32.6.3
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
flutter_keyboard_visibility-3.3.04.0.2
flutter_plugin_android_lifecycle-1.0.111.0.11
http-0.12.20.12.2
http_parser-3.1.43.1.4
image-2.1.192.1.19
image_picker_platform_interface-1.1.11.1.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
json_annotation-3.0.13.1.1
logging-0.11.40.11.4
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.8.0-nullsafety.31.8.0-nullsafety.3
permission_handler_platform_interface-2.0.12.0.1
petitparser-3.1.03.1.0
plugin_platform_interface-1.0.31.0.3
pointycastle-1.0.22.0.0
random_string-2.1.02.1.0
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
vin_decoder-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs