flutter_floatwing 0.2.1 copy "flutter_floatwing: ^0.2.1" to clipboard
flutter_floatwing: ^0.2.1 copied to clipboard

PlatformAndroid

A Flutter plugin that makes it easier to make floating/overlay window for Android with pure Flutter.

74
likes
110/ 140
pub points
77%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

29 out of 119 API elements (24.4 %) have documentation comments.

Some symbols that are missing documentation: flutter_floatwing, flutter_floatwing.DragCallback, flutter_floatwing.Event.Event.fromMap, flutter_floatwing.EventManager, flutter_floatwing.EventManager.EventManager.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:flutter_floatwing/flutter_floatwing.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:flutter_floatwing/flutter_floatwing.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:flutter_floatwing/flutter_floatwing.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:flutter_floatwing/flutter_floatwing.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:flutter_floatwing/flutter_floatwing.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

WARNING: The value of the local variable 'halfWidth' isn't used.

lib/src/constants.dart:102:9

    ╷
102 │     var halfWidth = width / 2;
    │         ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/constants.dart

WARNING: The value of the local variable 'halfHeight' isn't used.

lib/src/constants.dart:103:9

    ╷
103 │     var halfHeight = height / 2;
    │         ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/constants.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

74
likes
110
pub points
77%
popularity

Publisher

verified publisherzoe.im

A Flutter plugin that makes it easier to make floating/overlay window for Android with pure Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_floatwing