flutter_firebase_ui 0.0.13
flutter_firebase_ui: ^0.0.13 copied to clipboard

Firebase auth UI, dart package try to mimic the firebaseUI.

1
likes
55 / 130
pub points
48 %
popularity

We analyzed this package on Jun 19, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package has a git dependency.

pubspec.yaml:15:5

   ╷
15 │ ┌     git: git://github.com/diegoveloper/flutter_twitter_login.git
16 │ │ 
17 │ │   firebase_auth: ^0.6.2+1
   │ └──^
   ╵

The pub site doesn't allow git dependencies.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:10:59

   ╷
10 │ <p>For help getting started with Flutter, view our online <a href="http://flutter.io/">documentation</a>.</p>
   │                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 131 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_firebase_ui/flutter_firebase_ui.dart that imports:
  • package:flutter_firebase_ui/login_view.dart that imports:
  • package:flutter_firebase_ui/utils.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/email_view.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/utils.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.6.2+10.6.61.4.1
flutterflutter0.0.00.0.0
flutter_facebook_login^1.1.11.2.03.0.0
flutter_twitter_loginnull1.1.01.1.0
google_sign_in^3.2.13.3.0+15.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
firebase_core-0.2.5+11.3.0
meta-1.3.01.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.6.2+1` on firebase_auth does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `^1.1.1` on flutter_facebook_login does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_facebook_login to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

1
likes
55
pub points
48%
popularity

Publisher

Unknown

Firebase auth UI, dart package try to mimic the firebaseUI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

firebase_auth, flutter, flutter_facebook_login, flutter_twitter_login, google_sign_in

More

Packages that depend on flutter_firebase_ui