flutter_firebase_chat_sdk 0.0.3
flutter_firebase_chat_sdk: ^0.0.3

Flutter Android iOS

A package that used the power of firebase to create a chat SDK. Motivation behind this project was to create an all in one sdk that would make it easier for developers to create a chat app. Using this

3
likes
60 / 110
pub points
18 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 89 API elements (18.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_firebase_chat_sdk/flutter_firebase_chat_sdk.dart that imports:
  • package:firebase_messaging/firebase_messaging.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/auth/auth.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/chat/chat.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^0.14.0+20.14.3+10.14.3+1
cloud_functions^0.6.00.6.0+10.7.1
firebase_auth^0.18.0+10.18.3+10.18.3+1
firebase_core^0.5.00.5.2+10.5.2+1
firebase_database^4.0.04.3.04.3.0
firebase_messaging^7.0.07.0.37.0.3
firebase_storage^4.0.04.0.15.1.0
state_notifier^0.6.00.6.00.6.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
cloud_firestore_platform_interface-2.2.02.2.0
cloud_firestore_web-0.2.1+10.2.1+1
cloud_functions_platform_interface-2.0.03.0.2
cloud_functions_web-2.0.03.1.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
firebase-7.3.27.3.2
firebase_auth_platform_interface-2.1.32.1.3
firebase_auth_web-0.3.2+10.3.2+1
firebase_core_platform_interface-2.1.02.1.0
firebase_core_web-0.2.1+10.2.1+1
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on cloud_functions does not support the latest published version `0.7.1`

pubspec.yaml:19:20

   ╷
19 │   cloud_functions: ^0.6.0
   │                    ^^^^^^
   ╵
The constraint `^4.0.0` on firebase_storage does not support the latest published version `5.1.0`

pubspec.yaml:22:21

   ╷
22 │   firebase_storage: ^4.0.0
   │                     ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
60
pub points
18%
popularity

A package that used the power of firebase to create a chat SDK. Motivation behind this project was to create an all in one sdk that would make it easier for developers to create a chat app. Using this SDK developers can focus on the basic functionality of their app rather then worrying about setting up and developing a chat server. The project is still in development phase but you are welcome to use it in your app and contribute to the project if you needed some more features or if you would like to improve something.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

nishithsingh24@gmail.com

License

MIT (LICENSE)

Dependencies

cloud_firestore, cloud_functions, firebase_auth, firebase_core, firebase_database, firebase_messaging, firebase_storage, flutter, state_notifier

More

Packages that depend on flutter_firebase_chat_sdk