flutter_facebook_appevents 0.2.0 icon indicating copy to clipboard operation
flutter_facebook_appevents: ^0.2.0 copied to clipboard

flutter_facebook_appevents integrates Facebook App Events to your Flutter app.

0
likes
40/ 140
pub points
28%
popularity

The package version is not analyzed, because it does not support Dart 3. Until this is resolved, the package will receive a pub score of 0.

We analyzed this package 4 days ago, and awarded it 40 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: Failed to run dartdoc

  • dartdoc failed, see task-log.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 50icon to trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/services.dart'.

lib/src/flutter_facebook_appevents.dart:4:8

  ╷
4 │ import 'package:flutter/services.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flutter_facebook_appevents.dart

ERROR: Undefined class 'MethodChannel'.

lib/src/flutter_facebook_appevents.dart:8:16

  ╷
8 │   static const MethodChannel _channel =
  │                ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flutter_facebook_appevents.dart

icon indicating section status
Support up-to-date dependencies
0 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.2.0-134.1.beta. Cannot run `flutter pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.2.0-134.1.beta.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.1.2)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analysed with Pana 0.21.37, Flutter 3.13.5, Dart 3.1.2.

0
likes
40
pub points
28%
popularity

Publisher

verified publisher iconzonble.net

flutter_facebook_appevents integrates Facebook App Events to your Flutter app.

Repository (GitHub)
View/report issues

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_facebook_appevents