flutter_extensionz 4.2.2 copy "flutter_extensionz: ^4.2.2" to clipboard
flutter_extensionz: ^4.2.2 copied to clipboard

A set of Flutter extensions I use in various projects. Including BuildContext, Color extensions and more.

2
likes
150/ 160
pub points
53%
popularity

We analyzed this package 31 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 73 API elements (74.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_extensionz, flutter_extensionz.BuildContextExtension, flutter_extensionz.ColorExtension, flutter_extensionz.FocusScopeExtension, flutter_extensionz.MediaQueryExtension.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/buildcontext_extension.dart:1:1

  ╷
1 │ part of flutter_extensionz;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/buildcontext_extension.dart

INFO: The part-of directive uses a library name.

lib/src/color_extension.dart:1:1

  ╷
1 │ part of flutter_extensionz;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/color_extension.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
150
pub points
53%
popularity

Publisher

verified publishermj12358.dev

A set of Flutter extensions I use in various projects. Including BuildContext, Color extensions and more.

Repository (GitHub)
View/report issues

Topics

#flutter #extension

Documentation

API reference

Funding

Consider supporting this project:

www.buymeacoffee.com

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_extensionz